Emails sending problem

Resolved
Operational
Started about 2 years ago Lasted 3 days

Affected

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Identified
    Identified

    We have identified the issue, which impacts outgoing emails delivery. This means emails such as password reset, won't be delivered until the issue is resolved. Once we have more updates, we will update this case.