Completed
Billing system maintenance

Starts
Wednesday, May 11th 2022 at 12:40 PM
Status
Resolved after about 1 hour
Affects
Support
Ticketing & Email System
  • Completed
    Wednesday, May 11th 2022 at 1:40 PM

    Maintenance has completed successfully

  • In progress
    Wednesday, May 11th 2022 at 12:40 PM

    Maintenance is now in progress

  • Planned
    Wednesday, May 11th 2022 at 12:40 PM

    We are currently doing maintenance on our billing system. Some actions may be unavailable.